Google Certified Professional Data Engineer

Sign Up Free or Log In to participate!

Lab shown is not working. Have tried changing JAVA version to 8 but still same issue:

Lab shown is not working. Have tried changing JAVA version to 8 but still same issue:

 WARNING: An illegal reflective access operation has occurred WARNING: Illegal reflective access by (file:/home/cloud_user_p_2f4f9f54/.m2/repository/org/jruby/jruby-complete/1.6.8/jruby-complete-1.6.8.jar) to metho d java.lang.Object.registerNatives() WARNING: Please consider reporting this to the maintainers of WARNING: Use –illegal-access=warn to enable warnings of further illegal reflective access operations WARNING: All illegal access operations will be denied in a future release ArgumentError: wrong number of arguments (0 for 1) method_added at file:/home/cloud_user_p_2f4f9f54/.m2/repository/org/jruby/jruby-complete/1.6.8/jruby-complete-1.6.8.jar!/builtin/javasupport/core_ext/object.rb:10 method_added at file:/home/cloud_user_p_2f4f9f54/.m2/repository/org/jruby/jruby-complete/1.6.8/jruby-complete-1.6.8.jar!/builtin/javasupport/core_ext/object.rb:129 Pattern at file:/home/cloud_user_p_2f4f9f54/.m2/repository/org/jruby/jruby-complete/1.6.8/jruby-complete-1.6.8.jar!/builtin/java/java.util.regex.rb:2 (root) at file:/home/cloud_user_p_2f4f9f54/.m2/repository/org/jruby/jruby-complete/1.6.8/jruby-complete-1.6.8.jar!/builtin/java/java.util.regex.rb:1 require at org/jruby/ (root) at file:/home/cloud_user_p_2f4f9f54/.m2/repository/org/jruby/jruby-complete/1.6.8/jruby-complete-1.6.8.jar!/builtin/java/java.util.regex.rb:42 (root) at thirdparty/hirb.rb:39

3 Answers

Please follow these instructions :

  • once you have upgraded java, this should work.

First do this – 

sudo apt-get update

sudo apt-get install openjdk-8-jdk-headless

export JAVA_HOME=$(update-alternatives –list java | tail -1 | sed -E ‘s//bin/java//’)

then – (make sure the Cloud Big Table API is enabled)

 git clone

cd cloud-bigtable-examples/quickstart


it should work after this.

Chenming Yong

This method is working, thanks Vaibhav!

Brandon Jackson

This worked for me too.

For me the issue was also that JAVA_HOME pointed to java11.
I did:
– update-alternatives –list java (listed java11 and java8 paths)

  • update-alternatives –set java /usr/lib/jvm/java-8-openjdk-amd64/jre/bin/java

Then running ./ works

Sign In
Welcome Back!

Psst…this one if you’ve been moved to ACG!

Get Started
Who’s going to be learning?