Google Certified Associate Cloud Engineer 2020

Sign Up Free or Log In to participate!

No File in my bucket after VM creation

there is no file in my bucket after VM creation. I’ve set startup script and metadata correctly.

Abhishek Danej

It worked for me … but took around 20 minutes.

Nagaraj Ds

Yes, it worked for me as well. Took some time to though to create the file in the bucket

Jan Olaf Eriksen

You can also follow along in the stackdriver to see if the process is done, for me when the cleaning up started(and appeared in the stackdriver) the file was in the bucket. It took around 10 minutes maybe so be patient and follow the stackdriver

2 Answers

It takes a while to create the file in the storage bucket. However, you can verify if the stackdriver agent is installed and presently running on the VM instance by executing the following command. 

$ sudo service google-fluentd status

1. edit the startup script and remove the apt-get -yq upgrade line before using it
2. You need to add scope to the gce during creation (if using gcloud) as described here: 
https://cloud.google.com/compute/docs/access/create-enable-service-accounts-for-instances#serviceaccountname

Sign In
Welcome Back!

Psst…this one if you’ve been moved to ACG!

Get Started
Who’s going to be learning?