Google Certified Associate Cloud Engineer 2020

Sign Up Free or Log In to participate!

Initializing your Cloud Shell Editor never finishes

Hi guys, I am going through the course and I am stopped at the Cloud Shell Editor. When I click on the editor pen icon, it opens a new window and has spinning circle and states "Initializing your Cloud Shell Editor" for about 20 minutes while I tried to diagnose this issue. 

I’ve cleared cache and cookies, running in Incognito (and also tested in Safari using Private mode). I’ve also run the gcloud init command with default keep all info answers to prompts. 

Still fails. What now?

Alfonso Rodriguez

Happening to me also. Anyone have a solution?

4 Answers

Cloud Shell is basically just a small and week virtual machine with Linux Shell. So you might have experienced a saturation of computing capacity of the underlying Cloud Shell Machine.

There’s an option called [Boost Cloud Shell], which will temporarily speed up the Cloud Shell Machine for 24 hours. I would suggest you to try it and see if if can help you to launch the Cloud Shell Editor faster.

It could be due to a limitation in the Incognito mode. When I tested outside Incognito, it worked fine.

I had the same issue when using Brave in standard and incognito modes. After taking shields down it then loaded in incognito mode.

I am testing outside incognito mode, the ‘Connecting to Shell Editor’ circle is still loading for me. I also no longer see a boost option for the console.

Sign In
Welcome Back!

Psst…this one if you’ve been moved to ACG!

Get Started
Who’s going to be learning?