Google Certified Associate Cloud Engineer 2020

Sign Up Free or Log In to participate!

Gcloud list displays flatlist instead of table format

Take "glcoud projects list" as an example.

If I run this in cloud shell, the output is as follows:

PROJECT_ID: my-user-project-324414

NAME: My User Project


PROJECT_ID: reference-flux-326616

NAME: Services Exploration Labs


I would like it to output like this:


my-user-project-324414      My User Project      12345

eference-flux-326616     Services Exploration Labs     67890

I have Googled high and low… just can’t figure it out.

Philipp Jansen

Same behaviour on my side. I tried all the different format options at but without much success.

Philipp Jansen

Interestingly the output while running gcloud in a e.g. iTerm directly on the OS is still pretty-printed

1 Answers

I also had the same problem, turns out that I had the accessibility option turned on. 

You can use the following command to turn it off 

gcloud config set accessibility/screen_reader false

Sign In
Welcome Back!

Psst…this one if you’ve been moved to ACG!

Get Started
Who’s going to be learning?