Google Certified Associate Cloud Engineer 2020

Sign Up Free or Log In to participate!

Creating an Instance – Service account scopes – There’s no scope settings

During a previous lab that we did in one of the videos, we created a compute engine instance and we were able to set access scopes for that instance. When I tried to do that for this lab, there were no access scopes options. It allows me to choose a service account, and it says access scopes, but it doesn’t actually give me the options to define any access scopes, or choose any options. It’s just a field that says access scopes, but there’s nothing for me to do in that field. Is this a recent update? Is this maybe a result of some project level settings that I have?

Debasish Panda

I’m facing the same problem too..

1 Answers

Did you select the option "Set access for each API"? The access scopes are displayed, if and only if you select this option.

Celeste Wilson

I wasn’t able to find that option in this project. I know the button you’re talking about because I could find it in other projects, but not in my challenge lab project. This project compute engine didn’t have any option to set API scopes. For whatever reason this problem was project wide, but when I just restarted and created a new project for the lab it was fine and I could configure the API access scopes. I just don’t understand what I did to the first project to remove that option when I configured it. I’m fairly certain that I set it up just as I’ve done every other time, I wonder if it was just a weird bug or something that I did.

Sign In
Welcome Back!

Psst…this one if you’ve been moved to ACG!

Get Started
Who’s going to be learning?