Google Certified Associate Cloud Engineer 2020

Sign Up Free or Log In to participate!

Bucket and File level Access not working

I made new bucket with "Fine Grain" access, made a file public and it was opening on another laptop however after removing the access the file is still visible. Changed the Bucket access to "Public" and then removed "all Users" and even then I see discrepancies between the rights and file opened in browser (2 laptops, and mobile too).

Does the change in access rights take time ?. It looks that they are updated on real time however even after deleting Cache and opening "Private Windows" the link still works

1 Answers

Hi Amit. I just tried what you did:

1. Create a new fine-grain bucket.

2.  Uploaded an image.

3. Changed permissions for the image to include "Public"

4. Copied the new link and viewed in browser.

5. Changed permissions again to remove "Public"

6. Opened another browser and tried the link. Got this message: "AccessDeniedAccess denied.Anonymous caller does not have storage.objects.get access to the Google Cloud Storage object."

You may see the image in the same browser in a different tab for a bit because of caching. I find that Chrome is really tenacious when it comes to caching. However, no one else – even if they have the URL – will be able to view the image.

Hope this helps – Joe

Ameya Bhave

Hi – I had the same problem as Amit. In fact, when I removed the public file permission, the bucket list page was still showing the permission as ‘Public’ and when I opened the Edit permissions tab, the public permission was still there – almost as if the change had not taken effect. The public file url continued to work in Chrome Incognito even after I deleted the bucket! Only when I tried Firefox did I get the ‘No such bucket’ error message. Really weird!

Sign In
Welcome Back!

Psst…this one if you’ve been moved to ACG!

Get Started
Who’s going to be learning?