Google Certified Associate Cloud Engineer 2020

Sign Up Free or Log In to participate!

Allusers permissions in buckets

When adding allUsers to edit the permissions for the object in a bucket, I get an error saying: "Unknown user: allusers", did anyone else get this?

2 Answers

Open the Cloud Storage browser in the Google Cloud Console.

Open the Cloud Storage browser

Check the Access control column for the bucket containing the object you want to make public. If the column reads Fine-grained, proceed to the next step. If the column reads Uniform, you cannot use the following steps to make individual objects in the bucket publicly readable. Instead, grant public readability to all objects in the bucket, or use signed URLs.

Click on the name of the bucket that contains the object you want to make public, and navigate to the object if it’s in a subdirectory.

Click the more actions menu () associated with the object that you want to make public.

Select Edit permissions from the drop-down menu. If the option does not exist, you may have Uniform access control enabled. See Step 2 for more details.

In the overlay that appears, click the + Add entry button.

Add a permission for allUsers.

Select Public for the Entity.

Select allUsers for the Name.

Select Reader for the Access.

Click Save.


I believe you have kept entity as "user" only and change name column to "allUser". Instead you should select entity as public from drop down , from name column drop down select allUser and then access you want to provide.

Sign In
Welcome Back!

Psst…this one if you’ve been moved to ACG!

Get Started
Who’s going to be learning?