Kubernetes Deep Dive

Sign Up Free or Log In to participate!

kubernetes pods unable to connect to internet

Following Nigel Poulton’s Kubernetes Deep Dive , Chapter 5 "Networking" Demo,  I get the following time-out error when i run ->

apt-get update 

Error: 

test>kubectl exec -it pingtest-57cc454bcd-bxpgf bash

root@pingtest-57cc454bcd-bxpgf:/# apt-get update

Err:1 http://archive.ubuntu.com/ubuntu bionic InRelease

Temporary failure resolving ‘archive.ubuntu.com’

Err:2 http://security.ubuntu.com/ubuntu bionic-security InRelease

Temporary failure resolving ‘security.ubuntu.com’

0% [Connecting to archive.ubuntu.com]

Appears to be a DNS Related error. Tried fixing via applying and creating a DNS pod.

But it says it already exists.

apiVersion: v1

kind: ConfigMap

metadata:

name: kube-dns

namespace: kube-system

data:

upstreamNameservers: |

["8.8.8.8"]

SGM2019

Hello, Did you manage to fix this. I got the same issue. No editor in the bin. So not possible to modify the file

0 Answers

Sign In
Welcome Back!

Psst…this one if you’ve been moved to ACG!

Get Started
Who’s going to be learning?