Kubernetes Deep Dive

Sign Up Free or Log In to participate!

how to hammer our cluster

I am not able to use this command to create the cluster hammer:

kubectl run -i –tty loader –image=busybox /bin/sh

I get a message with ‘kubectl run –generator=deployment/apps.v1 is DEPRECATED and will be removed in a future version. Use kubectl run –generator=run-pod/v1 or kubectl create instead.’

The deployment is created but the pods are remaining in a pending state for.

Is there another way people are accomplishing the same thing?

Jon Harris VMware

Got the same error, but it was more of a warning that it was deprecated. Still worked fine in my k8s instance. What version of k8s are you running? Mine is v1.14.10-gke.17. As you can see I am running on GKE.

Mexicoder

can’t remember but i think i just ended up using Apache Benchmark. i was using GKE as well. If you install it on the Cloud Shell it is very easy to do some basic load tests.

Mexicoder

here is a link to install Apache Benchmark that might help someone running into a similar issues. NOTE: you may need to use sudo to run some of these commands https://www.tutorialspoint.com/apache_bench/apache_bench_environment_setup.htm

Mexicoder

I am not a Linux expert so if anyone has a better way to do it on Google Cloud Shell please let me know

0 Answers

Sign In
Welcome Back!

Psst…this one if you’ve been moved to ACG!

Get Started
Who’s going to be learning?