Google Certified Professional Data Engineer

Sign Up Free or Log In to participate!

Issue with ./cloud_sql_proxy

./cloud_sql_proxy -instances=playground-s-11-82539a2d:us-central1:forumdb=tcp:3306 -credential_file=./playground-s-11-82539a2d-0e04d1fb026f.json &

seeing the error

cloud_user_p_e7c46d84@testvm:~$ 2020/12/22 19:09:03 Rlimits for file descriptors set to {&{8500 1048576}}

2020/12/22 19:09:03 using credential file for authentication;

2020/12/22 19:09:03 errors parsing config:

googleapi: Error 403: Cloud SQL Admin API has not been used in project 57335710336 before or it is disabled. Enable it by visiting then re

try. If you enabled this API recently, wait a few minutes for the action to propagate to our systems and retry., accessNotConfigured

1 Answers

Hi there,

The solution is actually in the error message you see. You need to enable the Cloud SQL Admin API to use the cloudsqlproxy. The error message provides you with a direct link to do this, or you can do it manually through the APIs & Services dashboard in the GCP console.

Hope this helps!

Sign In
Welcome Back!

Psst…this one if you’ve been moved to ACG!

Get Started
Who’s going to be learning?