Google Certified Associate Cloud Engineer 2020

Sign Up Free or Log In to participate!

Unable to make a file public in a bucket

While following instructions on the storage video, I uploaded 3 files to my newly created bucket. Then, as directed, I tried to make one of the files public by clicking on Edit Permissions. When I did, I get this error: 

"Cannot get legacy ACL for an object when uniform bucket-level access is enabled. Read more at"

I have not tinkered with any ACL or IAM settings. Please could someone help?


Dionne Noella Barretto

You could edit the bucket permissions to ensure its set to fine grained as opposed to uniform to allow for per file level permission edit ability. 🙂


Thanks Dionne

Ameya Bhave

Thanks Dionne – that worked! Much appreciated!

Ankit Kumar

HI Dionne !! Thanks for the reply. I got the same issue and enabled the fine grain access as opposed to uniform. But, now I am getting "Unknown user: allUsers" error. Can you please help me out ?

Kyle Newton

Ankit, I was getting the same error, but simply scroll down to "Public" and then select from the drop down allUsers or allAuthenticatedUsers 🙂

0 Answers

Sign In
Welcome Back!

Psst…this one if you’ve been moved to ACG!

Get Started
Who’s going to be learning?