Google Certified Associate Cloud Engineer 2020

Sign Up Free or Log In to participate!

Service account empty

I’m following the video step by step and the thing I did enable Compute Engine API.

Once I navigate to IAM Admin I have only 3 roles compute Engine Service Agent, google APIs Service Agent and my user account.

Video shows 4 roles why showing only 3 on my profile?

I did navigate to service account it’s empty and I’m unable to create VM.

Does that happen to anyone 


Balaji M

You are missing "Compute service agaent" member. It is very unlikely to see a issue like this. If you use the gcp console the api’s will be enabled automatically and so does the service account. But if you use the cloud shell, you have to use the proper command to enable the services(i.e API’s) else it may throw an error. I suggest you to go through this link: And also try this command "gcloud services enable –help" this lists the usage of the command. Hope this resolves your issue.

3 Answers

I don’t recall having this issue. The enabling of Compute API via console and via gcloud both give me the default, project-wise Compute Service Account automatically.

You could try to:

  • Disable the API and enable it again.

  • Or just go ahead and create a service account by yourself. Good chance to practice though 😉

wait for a minute and reload the page , you should be good

I had the same issue and thought I missed a step. 

It looks that after enabling the API it could still take some minutes until the service accounts are created.

Sign In
Welcome Back!

Psst…this one if you’ve been moved to ACG!

Get Started
Who’s going to be learning?