Google Certified Associate Cloud Engineer 2020

Sign Up Free or Log In to participate!

Seeing 403 Insufficient permission in Stackdriver logs

I have enabled access for the service account in Cloud API access scopes using both options: 1. enabling access to write to storage only. 2. Allow full access to all cloud APIs. 

However, I am getting same 403 insufficient permission in both cases.

3 Answers

I couldn’t figure out why it didn’t work on my first instance. However, I used the steps again and created a new instance and it worked!

I ran into the same issue. If you create the instance without setting the API scope access before the creation of the virtual machine, you get 403 forbidden. However, when using the create similar option it works fine on a newly created machine. I’ve left the first virtual machine running (i.e. the virtual machine experiencing the 403 error) in the hope it updates within an hour or so. I’ll revert if this updates.

Just a quick update – It took approximately 15-20 minutes for the change to be reflected. So If you miss the step to enable the service APIs on the creation of the virtual machine your options are to 1) create a similar virtual with the correct settings for immediate effect or 2) have patience when waiting for the changes to occur, it’s not immediate and there was about 15-20 minutes latency for the change to take effect.

Sign In
Welcome Back!

Psst…this one if you’ve been moved to ACG!

Get Started
Who’s going to be learning?