Google Certified Associate Cloud Engineer 2020

Sign Up Free or Log In to participate!

No file in bucket. Does the start up script need to be updated at all?

Does the start up script need to modified at all before pasting in when creating the VM? I do not have anything show up in my bucket after redoing this lab a couple times in different accounts.

Titus Joyson

It may take few min for the logs to appear in the bucket if there is no error, You can track instance logs in Logs Explorer, It will give better idea on what’s going on

5 Answers

Nope, the script does not need to be edited at all.

It’s helpful to check logs on your VM, what exactly was happened. The possible reason could be access permissions.

Still for me also same, nothing got reflecting in bucket after creating VM with given script

The instance you create is very small so it takes time to process the whole script and get to the part where it copies the log to the bucket. I had to wait about 10 minutes before it appeared. If you want to make sure things are going smothly, you can log into the instance and check for the running commands.

The output of the startup script can be monitored with the folowing command:

sudo journalctl -u google-startup-scripts.service

Shivamdsm

even i am facing the same error,instance is running but the file is not created in cloud storage.I have tried running the above command as

Shivamdsm

i tried to the run your command ,i am getting message "No journal files were found.".Could you please suggest

Shivamdsm

stack driver logging option is not visible under logs, in compute engine section Logs: Cloud Logging Serial port 1 (console) Serial port 2 Serial port 3 Serial port 4 Here are the options whihc are available,Could you please suggest

Sign In
Welcome Back!

Psst…this one if you’ve been moved to ACG!

Get Started
Who’s going to be learning?