Google Certified Associate Cloud Engineer 2020

Sign Up Free or Log In to participate!

Creating and Linking a Google Project to Accounts via the CLI

Logged in as the Billing User (not admin), I created a project via the CLI, then linked it (gcloud beta billing projects link… api) to the billing account, but it only shows when logged in with the billing admin id and not the billing user id.  Does any know how to do this?  Thanks…

Rene Solis

In the GCP Eng Associate Course, you’re shown how to do this via the console, and it works great, but when running it through the CLI, there is a step I seem to be missing.

2 Answers

Hello, Rene.  Could you please clarify what you mean, here?  I’m not quite sure I follow.  Is the problem when you’re running some command?  If so, what is the command, and what is the result you see?  And what do you expect to see, instead?

It’s also possible that this might be based on a misunderstanding of how billing accounts and their related roles work, so you might want to watch the Security section–and especially this lecture–to get a better sense for how this should work and what might be causing what you’re seeing.

Please let us know what you find!  Thanks!


I had no issue at the CLI once I worked it all out. My final working steps were:
1 – create project
2 – config set project
3 – list billing accounts

( billing accts output )

4 – link project to billing account

Before I worked out those steps, I received a billing account error when later trying to enable on the project. I’m not sure what you mean by "it only shows when logged in with the billing admin id and not the billing user id"; I did not check the console if this is what you meant, but I knew that the account was associated because I was able to enable the API on the project at CLI.

Sign In
Welcome Back!

Psst…this one if you’ve been moved to ACG!

Get Started
Who’s going to be learning?