Google Certified Associate Cloud Engineer 2020

Sign Up Free or Log In to participate!

Console issue!

When I hit the Tab key after typing gs://, my console is not auto-completing with bucket name. why it’s not working?

2 Answers

You’re not alone, as this seems to be an issue with gsutil rather than the environment where you run it. When I firstly used gsutil the auto-completion still worked. But after a few updates of the gcloud commands suite, the auto-completion of gsutil went away, both on Cloud Shell or on a computer.

I have colleagues doing the course with me, and it appears to be browser-related. I’m on Firefox 80.0.1 and it doesn’t work, whereas a colleague is on Chrome and it is working. One solution other people have used is to download the SDK, but that takes some setup. For the tutorial, I’m just keeping my bucket names short.

Chris Nicholas

I wish it was that easy for me.. I have tried with Firefox, Chrome, Edge and IE and experienced the same failure each time. I gave up and provided feedback. Luckily I can type pretty fast and accurately.

Jari Rantala

Same on OSX chrome. No tab. Both for buckets and local cloud shell files.

Sign In
Welcome Back!

Psst…this one if you’ve been moved to ACG!

Get Started
Who’s going to be learning?