Google Certified Associate Cloud Engineer 2020

Sign Up Free or Log In to participate!

Basic issue with the app engine lab challenge – Getting Started with App Engine (Go)

Hi,

very novice question but an hour of googling hasn’t helped me to resolve it so I throw out the question here, might hopefully help someone else too…

I picked the Getting Started with App Engine (Go) lab (https://codelabs.developers.google.com/codelabs/cloud-app-engine-go) as I thought it would be a good starting point. However running dev_appserver.py in the cloudshell fails and I can’t really see why. I thought cloudshell would be up to date with all latest greatest and ready to rock… 

The error is the following: OSError: [Errno 2] No such file or directory: ‘/google/google-cloud-sdk/platform/google_appengine/goroot-1.9/pkg/tool’

I appreciate this isn’t an issue related to the ACE course and possibly a bit to narrow to post here, but on the other hand I think that if there are basic issues with Cloudshell it might be something that other GCP novices besides me will be affected by and some guidance could be helpful.  

Thx
/ola

Dhananjay Tripathi

That tutorial seems to be out of date. I myself am not familiar with go and tried it and ran into an issue with dev_appserver. The tutotrial doesn’t mention where you are suppose to get that file from.

Dhananjay Tripathi

I am able to get the go app running when I update the hello.go and app.yaml with content here https://github.com/GoogleCloudPlatform/golang-samples/tree/master/appengine/go11x/helloworld

Dan Burkland

Ran into the same issue, thanks for posting this @Dhananjay!

Antonio Saldivar

I ran into the same issue and just changing the runtime as follow "runtime: go111" it worked

0 Answers

Sign In
Welcome Back!

Psst…this one if you’ve been moved to ACG!

Get Started
Who’s going to be learning?