AWS Certified Solutions Architect - Associate (SAA-C02)

Sign Up Free or Log In to participate!

I was not able to open the Public IP4 address after creating the instance with bootstrap script copied from Resources section.

I didnt have existing instances from last session on user data. So I had created new instance, new security group and new key pair. For security group I gave SSH, HTTP and HTTPS.


Neither do I


Check if you opened http port to public (

4 Answers

You maybe need to wait for a little bit for httpd to install and initiate. If that didn’t work make sure you have http:// in your browser address line instead of https:// . When you click on "open address" link in Amazon console it will automatically opens https. If these didn’t work connect to your instance and check the logs for errors.

I had the same issue and I was not able to connect to my website…I tried at home wifi and from office network but nothing worked. I then used mobile data and surprisingly it worked.

I could never find out that why it didn’t work from home wifi. Office networks are usually restricted and result was expected.

Just opening HTTPS doesn’t automatically make it work. You would need to obtain and install a valid certificate etc. It’s all rather complex. As others mentioned, click on the url, and edit HTTPS to be only HTTP. This will generate a get request on port 80 rather than 443. You can see in the ACG videos they do this via the "not secure" next to the website url in the top of the screen, but it would have been handy if they actually specified that they did this I agree.

I have tried all the advice on this page but i am still struggling to open the public 1p4 address. Can anyone assist on what the problem maybe?

Thanks in advance.

Sign In
Welcome Back!

Psst…this one if you’ve been moved to ACG!

Get Started
Who’s going to be learning?