AWS Certified Solutions Architect - Professional 2020

Sign Up Free or Log In to participate!

The yaml scripts does not appear to be a cloudformation scripts

Template format error: YAML not well-formed. (line 128, column 34)

4 Answers


I just imported the scripts, and all went OK. Check if you’re not copying pasting unnecessary content.


One thing that I am not very happy with is that the instructions are not very clear … you’ll need to go to Cloud Formation and create a stack with the first script, and the UPDATE the existing stack with the second script.

Good luck!

You can get this YAML not well-formed if you copy/paste rather than upload the template.  Seems there are hidden characters somewhere with copy-paste from GitHub.

I got the same error. I had tried with 2 approaches — a. Copy Pasted from GitHub b. Saved the file using the browser . In both cases, I got this error. Later, I downloaded the GitHub project, extracted it, and uploaded the YAML file. I did not get any errors.


This ^^^

Jennifer Chavez

Fixed it for me as well, thanks!

Got a different error: Your requested instance type (t3.micro) is not supported in your requested Availability Zone (us-east-1e). Please retry your request by not specifying an Availability Zone or choosing us-east-1a, us-east-1b, us-east-1c, us-east-1d, us-east-1f.

But downloading the github repo and sourcing the file from the local drive fixed it.

Sign In
Welcome Back!

Psst…this one if you’ve been moved to ACG!

Get Started
Who’s going to be learning?