AWS Certified Solutions Architect - Professional 2020

Sign Up Free or Log In to participate!

CloudFormation Template Error – format error: YAML not well-formed. (line 614, column 26)

Template format error: YAML not well-formed. (line 614, column 26). I receive this error when I attempt to import the Step 1 template for the lab.

Kevin Lewis

I read the response from a previous post on the same error and it stated that the script had fewer lines than what the error shows. None the less, I received the error.

2 Answers

Hi Kevin,

Yep, this has come up in the past.   I’m not able to locate the exact post, but I do recall it had something to do with copy-paste rather than upload from local or S3.   Seems copy-paste into the CloudFormation window does not format properly and leaves some hidden character in the script.   If you upload, it seemed to work.   Could you try this?


Sven Degenhardt

Same error, but neither loading from S3 bucket or local directory worked


Don’t right click on the file in GitHub and save as, this will add a load of html formatting to your Yaml file. As Brian says, view the RAW output and download that or copy / paste works if you are careful.

This works fine for me. In GitHub, either view the raw file and save it, or check out / download the repo. Then upload. Don’t copy and paste from the formatted view.

Sign In
Welcome Back!

Psst…this one if you’ve been moved to ACG!

Get Started
Who’s going to be learning?