AWS Certified Solutions Architect - Professional 2020

Sign Up Free or Log In to participate!

CloudFormation Script does not work

Hi all

I tried to install the first CloudFormation Script:

But in both region North-Virginia and Ohio the script fails. For the WebServerInstance it fails with the message: The requested configuration is currently not supported. Please check the documentation for supported configurations. (Service: AmazonEC2; Status Code: 400; Error Code: Unsupported; Request ID: …)

Does anyone have the same issues here?


1 Answers

Hi Leo,

I just tried the script in US-EAST-1 and got a similar error with rollback about telling me that there was no capacity for a t3.micro in us-east-1e AZ….that AZ has been a hassle for me on this account for a long time.  I deleted the stack and retried…the second time it successfully created everything.  I was able to run the script successfully in US-EAST-2 too.

A couple things to try:

1) If you’re trying a copy/paste into the Designer, some people have had issues with tabs and spaces in the YAML.  Try to clone the repo locally, then use the Upload Template option.

2) Try another instance type than t3.micro.  Sometimes, t3.micros are all used up in an AZ or region, but t1 or t2 might also be available.

Let me know if these work!


Albin Furin

I had problems with invalid yml when downloading file directly from github. Cloning however work well, just as you described.

Leo Büttiker

Hi Scott, Thank you vor your very fast response. When I first tried it, I also tried with t2 and t3 and all of them did not work. But I tried a week after my question and then it did work. It just looks like this region was overloaded.

Sign In
Welcome Back!

Psst…this one if you’ve been moved to ACG!

Get Started
Who’s going to be learning?