AWS Certified Solutions Architect - Professional 2020

Sign Up Free or Log In to participate!

Cloudformation error setting up the lab

Creating the cloudformation stack with the Step_1_Setup.yaml template fails with "Invalid value ‘VPC’ for domain". Changing to lowercase "vpc" solves the issue.

Matthew Loring

I get an error, "Template validation error: Template format error: YAML not well-formed. (line 530, column 26)"

martin selway

I have the same error. Looking at the file contents it seems to be HTML not YAML.

martin selway

Maybe the wrong file is attached?

martin selway

Ah I think I see the issue… right clicking the file and choosing save link as results in the github HTML page being downloaded. You need to click the link then copy and paste the YAML into a new document on your machine.

unmesh deshpande

thank you Martin


Another possibility is to clone the Git Repo using a Git client

2 Answers

Hi wongelz,

Thanks for the info.   Someone else was having a problem too with this script, but I’m unable to reproduce the problem…including yours.  In your case, looks like it’s specific to the EIP definition maybe?   What region are you using?    Are you using a region where you’ve built items before or is this a fresh region you’ve never used?

Thanks for the additional info!


Scott Pletcher

Closing out as I’m unable to replicate.

Fadi Tahan

Hi Scott, I copied and pasted the template into CloudFormation, but I am getting a null value not allowed error. Any ideas?

Scott Pletcher

Hi Fadi, I can replicate this error…by pasting the github text into the Designer. Seems like the Designer does not accept the use of !GetAtt and trys to assume FQDN is null. If you use the S3 or Upload from Local method, it should work for you.

Still failing.

17 Feb 2019 10:24:56 EIP CREATE_FAILED Invalid value ‘VPC’ for domain. (Service: AmazonEC2; Status Code: 400; Error Code: InvalidParameterValue; Request ID: 6a7d6d03-c6c7-4a30-b481-68910f6e380e)

Scott Pletcher

Just tried again and can’t replicate. Can you include which region you’re trying it and any sort of other logs?

Sign In
Welcome Back!

Psst…this one if you’ve been moved to ACG!

Get Started
Who’s going to be learning?