Certified Security - Specialty

Sign Up Free or Log In to participate!

VPC connection to private: enter passphrase?

I am attempting to ssh into my private vpc through my public one, I have followed all the steps listed below, and it is requiring a passphrase to connect still.  I also have double checked the rsa key to ensure nothing was distorted in the copy-paste.  Any help?

1) From your public EC2 instance, ping your private EC2 instance to ensure it’s up and running. 

2) Use nano to save to save the "mypvk.pem" file in your public instance

3) Confirm the .pem file was saved by executing "ls" command. This should list all the files in your working directory.

4) Once you can see the .pem file via the "ls" command, chmod 400 it.

5) While in the same working directory in which you saved the "mypvk.pem" file, execute the ssh command with the "-i" parameter, as shown exactly in the video.

0 Answers

Sign In
Welcome Back!

Psst…this one if you’ve been moved to ACG!

Get Started
Who’s going to be learning?