Certified Security - Specialty

Sign Up Free or Log In to participate!

Showing error when running Encrypt Key Material commands

When writing the following commands:

openssl rsautl -encrypt

-in PlaintextKeyMaterial.bin


-inkey PublicKey.bin

-keyform DER


-out EncryptedKeyMaterial.bin

it is showing the following error:

‘no key file specified

unable to load Private key’

I have entered my wrappingKey_….. in place of PublicKey.bin but still showing the following error. What can i do?

2 Answers

Were you using the wrappingkey name as is in place of publickey.bin?

Just rename the wrappingkey file to something simple : Example:  mywrap

I have seen errors happen if you just use the same name . It might be because there are multiple characters such _ ,- which might be breaking up the command.

I ran into the same error. Through research, I identified spacing as the issue. Removing the spaces between commands worked for me. When copy over the command be sure to remove any spacing between the lines.

Sign In
Welcome Back!

Psst…this one if you’ve been moved to ACG!

Get Started
Who’s going to be learning?