Certified Security - Specialty

Sign Up Free or Log In to participate!

error using pre-signed url

I did the lab when I try to use the URL I get an error page that states:

"The request signature we calculated does not match the signature you provided. Check your key and signing method."

To create the URL I used the AWS CLI on my local linux machine. The credentials are for the root account.

1 Answers

Hi there,

This could be a couple of different things, check to make sure the region used in CLI matches the region the bucket was created in. Also make sure the expire time hasn’t already passed (you created the URL to be good for 60 seconds, and a minute has passed by the time it was used).  Default is 3600s.

Muhtashim Ayub

S3 is global right?

Abrar Bin Yousuf

Nope. Regional. That’s why you have features like Cross Site Replication..


That fixed it for myself. My CLI config was is a different region than the bucket, got a redirect error. Changed the CLI config to match the region of the bucket and it worked.

Sign In
Welcome Back!

Psst…this one if you’ve been moved to ACG!

Get Started
Who’s going to be learning?